“Deprecated VMFS (ver 3) volumes found. Upgrading such volumes to VMFS (ver 5) is mandatory for continued availability on vSphere 6.7 hosts” hatasının giderilmesi

Bir LUN,ESXi Node’a ilk kez bağlandığında, ESXi dosya sisteminin sürümünü algılayamaz ve bu nedenle bir eşleşme döndürmek için onu geçerli dosya sistemi listesiyle karşılaştıramaz. Bazende ESXi 5.5 sürümüne sahip ESXi hostlarının 6.0 sürümüne yükseltilmesi sonrasında da bu hata ile karşılabilirsiniz. Aslında Lun’larınızın tamamı VMFS 5.0 olmasına ragmen Lun’lar üzerinde VMFS upgrade seçeneği de gelmeyecektir.

VMware ESXi 6.0 Patch Release ESXi600-201608401 ile bu sorun giderilmiştir. Bu sürümden daha yeni ESXi sunucularında bu sorunun çıkması durumunda bu hatadan etkilenen ESXi sunucularınun servisleri yeniden başlatılarak sorun giderilir.

Not : Management ajanlarının yeniden başlatılması, sanal makine güç durumunu etkilemez. Ayrıca, ESXi sunucularnda herhangi bir yeniden başlatma işlemide gerektirmez.

Bu sorunun giderilmesi için yapmanız gereken ilk işlem VMware ESXi host üzerinden “Management Agent” servislerinin yeniden başlatılması olacaktır. Bu işlem için ESXi host’a SSH ile başlanılır ve terminal ekranında services.sh restart komutu çalıştırılır. ESXi host’un bütün servisleri yeniden başlayacaktır ve ESXi kullanımdan kaldırılmış VMFS birimleri hakkındaki uyarıları otomatik olarak temizleyecektir. Üstelik bu bir sorun değildir ve false-positve bir hatadır. Göz ardı edilebilir çünkü herhangi bir işlevsellik arızasına neden olmayacaktır.